読者です 読者をやめる 読者になる 読者になる

Manager、きみが帰ったらクラス名ががらんとしちゃったよ

とりあえず前の議論を受けて(id:ABA:20060331#p1)、GameManager→Frame, PrefManager→Preference, SoundManager→Sound, StageManager→Stageなどに書き直してみた。あとGameManagerからゲーム状態関連の処理をGameStateに分離した。

「クラス名.メソッド名」の表記が「名詞.動詞」となるようにすべしという話をさらに一歩すすめて、ManagerとかHandlerとかは動詞の意味合いが含まれているからクラス名には不適当である、とまで考えるのは確かに1つの手なのかもしれん。まあBuilderとかGeneratorとかが付く単機能なクラスもあるだろうから、完全にそう言いきるわけにもいかんが。