読者です 読者をやめる 読者になる 読者になる

JavaScriptとECMAScriptとActionScriptのバージョンがよく分かりません

Firefox 1.5でのJavaScriptのバージョンは1.6。

で、ついでにE4Xもサポートしているらしいので、前に作ったActionScript 3.0用BulletMLパーサ(id:ABA:20051102#p1)を移植できるかなーと思ったら、Flex 2およびFlash 8.5のActionScript 3.0はJavaScript 2.0ベースで、つまり、ECMAScript edition 4ベースであり、Firefox 1.5のJavaScriptが1.6のECMAScript edition 3なので、つまり、2が8.5が3が2が4が1.5が1.6が3なので、無理らしい。

どうにかしてくれ。